Tuesday, March 25, 2025

Setting up a FreeBSD WIFI connection for RealTek 8821CE Chipset

 Setting up a FreeBSD WIFI connection for RealTek 8821CE Chipset

To get the Realtek RTL8821CE WiFi card working on FreeBSD, you’ll need to use the rtw88 driver, which supports this chipset, along with the appropriate firmware. Below is a step-by-step guide based on the current state of FreeBSD as of March 22, 2025. Note that this process assumes you’re running FreeBSD 14.0 or later, as support for RTL8821CE has improved in recent releases.   
Freebsd.org/where Get RELEASE 14.2 or newer  Here look for an image file to write to a usb flash device disk drive stick.
 FreeBSD CLI command to see what wifi chipset device you have and network connection
pciconf -lv | grep -A4 network
 Grok  Share link below
https://x.com/i/grok/share/OTZkqixA4P1FI2lMA9j29tYzm 
 
To get the Realtek RTL8821CE WiFi card working on FreeBSD, you’ll need to use the rtw88 driver, which supports this chipset, along with the appropriate firmware. Below is a step-by-step guide based on the current state of FreeBSD as of March 22, 2025. Note that this process assumes you’re running FreeBSD 14.0 or later, as support for RTL8821CE has improved in recent releases.

1. Verify Hardware Detection
First, confirm that FreeBSD detects your RTL8821CE card. Run the following command in a terminal:
pciconf -lv | grep -A4 network
Look for an entry mentioning "Realtek" and "RTL8821CE" (device ID 0xc821). If it’s listed as a network controller but not yet functional, it’s recognized but needs the driver and firmware loaded.
2. Check for the rtw88 Driver
The rtw88 driver, which supports the RTL8821CE, is included in FreeBSD’s kernel as of version 13.1 and later. To see if it’s available, check for the kernel module:
ls /boot/kernel | grep if_rtw88.ko
If the file exists, the driver is part of your system. If not, you may need to update your FreeBSD installation to a version that includes it (e.g., 14.0 or higher).
3. Install the Firmware
The rtw88 driver requires firmware to operate the RTL8821CE. FreeBSD provides this through the wifi-firmware-rtw88-kmod package. Install it with:
sudo pkg install wifi-firmware-rtw88-kmod
This package includes firmware files like rtw88/rtw8821c_fw.bin, which is specific to the RTL8821CE chipset. After installation, the firmware files will be placed in /boot/modules.
4. Load the Driver and Firmware
Load the rtw88 driver manually to test it:
sudo kldload if_rtw88
If your system has more than 4GB of RAM (common on modern machines), you’ll also need to set a loader tunable to ensure proper memory allocation for the driver. Edit /boot/loader.conf (create it if it doesn’t exist) and add:
compat.linuxkpi.skb.mem_limit="1"
Then reboot your system to apply this change:
sudo reboot
After rebooting, the driver should autoload via devmatch (enabled by default in /etc/rc.conf). To confirm it’s loaded, run:
kldstat | grep rtw88
You should see if_rtw88.ko listed.
5. Configure the WiFi Interface
Once the driver and firmware are loaded, a WiFi interface (e.g., rtw880) should appear. Check with:
ifconfig
If you see an interface like rtw880, create a WLAN interface:
sudo ifconfig wlan0 create wlandev rtw880
Connect to your WiFi network by editing /etc/wpa_supplicant.conf with your network details:
network={
    ssid="YourNetworkName"
    psk="YourPassword"
}
Then bring up the interface:
sudo ifconfig wlan0 up
sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf &
Obtain an IP address via DHCP:
sudo dhclient wlan0
6. Automate at Boot
To make this persistent, add the following to /etc/rc.conf:
wlans_rtw880="wlan0"
ifconfig_wlan0="WPA DHCP"
This ensures the interface is created and configured automatically on boot.
7. Troubleshooting
  • Driver Not Loading: If kldload if_rtw88 fails, ensure the firmware is installed and the module is present in /boot/kernel.
  • No Firmware Errors: Check dmesg for messages like "failed to load rtw88/rtw8821c_fw.bin". Reinstall the firmware package if needed.
  • Performance Issues: The rtw88 driver is still under development and may not be fully stable. If you encounter stalls or disconnects, try setting these sysctls:
    sudo sysctl compat.linuxkpi.rtw88_pci_disable_aspm=1
    sudo sysctl compat.linuxkpi.rtw88_disable_lps_deep=1
    These disable power-saving features that can cause issues.
Notes
  • The rtw88 driver supports RTL8821CE, but it’s not perfect yet. Some users report intermittent connectivity, especially on systems with more than 4GB of RAM, hence the mem_limit tunable.
  • If this doesn’t work, consider the wifibox project, which runs a Linux WiFi driver in a virtualized environment on FreeBSD. It supports RTL8821CE but requires more setup (see GitHub: pgj/freebsd-wifibox-alpine).
This should get your RTL8821CE working on FreeBSD with the right settings and firmware! Let me know if you hit any snags.

Friday, March 14, 2025

Ntpd Network Time Protocol Dameon setup in GhostBSD 25 install

Ntpd  Network Time Protocol Dameon setup in GhostBSD 25 install

 Kuntal S Kundu 🐧, [3/14/25 10:34 PM]

ntpd service was not enabled on start up, and the timezone (idk) was set to utc! (I selected India during installation!. and after log in into system it was showing correct time too!) so I first enabled ntpd, then run sudo tzsetup and set India from UTC. rebooted and boom
Solution?   ntpd was "yes" in rc.conf but not enabled

 FreeBSD Handbook

32.12.1.2. NTP entries in /etc/rc.conf

 

32.12.1.2. NTP entries in /etc/rc.conf

Set ntpd_enable=YES to start ntpd at boot time. Once ntpd_enable=YES has been added to /etc/rc.conf, ntpd can be started immediately without rebooting the system by typing:

# service ntpd start

Only ntpd_enable must be set to use ntpd. The rc.conf variables listed below may also be set as needed.

Set ntpd_sync_on_start=YES to allow ntpd to step the clock any amount, one time at startup. Normally ntpd will log an error message and exit if the clock is off by more than 1000 seconds. This option is especially useful on systems without a battery-backed realtime clock.

 

Reasons to try and test drive GhostBSD from a USB flash drive stick

Kuntal S Kundu 🐧, [3/14/25 10:34 PM]
ntpd service was not enabled on start up, and the timezone (idk) was set to utc! (I selected India during installation!. and after log in into system it was showing correct time too!) so I first enabled ntpd, then run sudo tzsetup and set India from UTC. rebooted and boom

Kuntal S Kundu 🐧, [3/14/25 10:34 PM]
ntpd was "yes" in rc.conf but not enabled

Kuntal S Kundu 🐧, [3/14/25 10:43 PM]
yesterday I had installed the ghostbsd, but lots of issues like tzsetup, screen tearing, appimage incompatibility made me to take decision of wiping out it and reinstall debian. But later I think again about ghostbsd, and I decided to take the challenge, so I installed it again today
 
Challenge Test Drive GhostBSD  25p2   ghostbsd.org/download 
 

manually  run update clock on system without a realtime clock like the raspberry Pi

NTPD,  NTPDATE   ntpd -q -g       or How to update, when clock is years off kilter, time? 

service ntpd start   #  another method from command line to start ntpd daemon 




 
 Setup NTPD  daemon for GhostBSD in  /etc/rc.conf file